Emulator speed Archimedes too fast

Everything you ever wanted to know about emulators and interpreters - but were afraid to ask.

Moderator: Alastair

Post Reply
Message
Author
User avatar
Alex
Posts: 615
Joined: Tue Oct 24, 2006 10:45 pm
Location: Netherlands

Emulator speed Archimedes too fast

#1 Post by Alex » Mon Mar 26, 2018 8:04 pm

I'm playing this adventure game which is partly real-time, but the emulator speed on my computer is too fast. Because of this I'm getting killed before I can type something in certain locations. Is there an Archimedes emulator where you can lower the emulator speed?

I use RPCEmu v0.8.13. I tried to use Arculator but didn't manage to get it working. I also found ARCem but this one did not respond at all on my computer although it seems more advanced than the RPCEmu emulator. I use a Windows 7 professional 64 bit computer with an Intel i7 920 processor @ 2,67GHZ, 8 core (using hyper-treading) and 12 GB ram.

Alastair
Posts: 687
Joined: Fri Nov 11, 2005 12:21 am

Re: Emulator speed Archimedes too fast

#2 Post by Alastair » Mon Mar 26, 2018 9:27 pm

Alex, the only mention of adjusting the speed of RPCEmu that I can find is to change the "Video refresh rate" under the emulator's settings, where a higher rate is supposed to slow down the emulation. If you combine this with using "RPCEmu-Interpreter" instead of "RPCEmu-Recompiler" you may be able to slow down the game enough on your computer.

In extremis, if the above proves unsatisfactory and you cannot get ArcEm to run under Windows how about running the RiscOS version of ArcEm inside RPCEmu! I would be surprised if that turned out to be too fast.

User avatar
Alex
Posts: 615
Joined: Tue Oct 24, 2006 10:45 pm
Location: Netherlands

Re: Emulator speed Archimedes too fast

#3 Post by Alex » Mon Mar 26, 2018 9:33 pm

Thank you. I'll try that.

Post Reply